読者です 読者をやめる 読者になる 読者になる

Unity5.4.0にしたら、Pluginが重複してるっていうエラーがでた

Unity5.4.0にしてiOSのビルドをしようと思ったら以下の様なエラーが、

Plugin 'GoogleMobileAds.framework' is used from several locations:
 Assets/Plugins/iOS/GoogleMobileAds.framework would be copied to <PluginPath>/GoogleMobileAds.framework
 Assets/Plugins/Android/GoogleMobileAds.framework would be copied to <PluginPath>/GoogleMobileAds.framework
Please fix plugin settings and try again.

どうも、GoogleMobileAds.frameworkが重複しているよーとのこと。

おかしいな。Plugin以下のiOSフォルダには、GoogleMobileAds.frameworkは一個しか無いのに...

他にもあるのは、Androidフォルダ以下だし...

っと見てみると、Androidフォルダ以下のGoogleMobileAds.frameworkの設定はAny Platformになっていた。

f:id:wkpn:20160805135349p:plain

どうも、これが原因らしい。

Anyのチェックを外してAndroidにチェックを入れるようにしたら無事ビルドできました。

Unity5.4.0になって、この辺りをよりしっかりチェックするようになったみたいですね。